Jamroom Logo Jamroom 5 Core
is now Open Source!
User Support Forum Archive (Read Only)
Jamroom Help:
from http:// to https:// problem
ukdenny



Joined: 20 May 2008
Posts: 257

Posted: 08/26/13 02:25 
I have just upgraded to a dedicated IP and has RapidSSL installed so that I can purchase the facebook module from the market place.
If I enter the url www.soundblitzrecords.com it's has it was and functions. But if I enter https://soundblitzrecords.com I get the index page and it does not display or function. ]

I cannot now login to Admin

Jamroom 4.3.1 Nova Red_Nebula

Could anyone point me in the right direction to fix this.
Thanks

Back to top
Brian
Jamroom Team


Joined: 09 Jul 2003
Posts: 37583
Location: Seattle, WA

Posted: 08/26/13 06:34 

ukdenny:
I have just upgraded to a dedicated IP and has RapidSSL installed so that I can purchase the facebook module from the market place.
If I enter the url www.soundblitzrecords.com it's has it was and functions. But if I enter https://soundblitzrecords.com I get the index page and it does not display or function. ]

I cannot now login to Admin

Jamroom 4.3.1 Nova Red_Nebula

Could anyone point me in the right direction to fix this.
Thanks


If you want to use SSL with Jamroom 4, you will have to run your entire site in SSL, all the time. to do so, make sure you have updated the URL in config/settings.cfg.php. Empty all caches, regenerate all profiles, and modify any templates that you have hard coded "http:' in.

Hope this helps!

- Brian


_________________
Make sure and check out:
* The Jamroom FAQ
* The Jamroom Documentation
Back to top
ukdenny



Joined: 20 May 2008
Posts: 257

Posted: 08/26/13 07:51 
I can change the config/settings.cfg.php but cannot login to do the other fuctions.



Last edited by ukdenny on 08/26/13 10:49; edited 2 times in total
Back to top
Brian
Jamroom Team


Joined: 09 Jul 2003
Posts: 37583
Location: Seattle, WA

Posted: 08/26/13 08:26 

ukdenny:
I can change the config/settings.cfg.php but cannot login to do the other fuctions.


Make sure you are logging in from the https: URL. If it is not loading, contact your hosting provider to make sure SSL is setup right in your account.

Hope this helps!

- Brian


_________________
Make sure and check out:
* The Jamroom FAQ
* The Jamroom Documentation
Back to top
ukdenny



Joined: 20 May 2008
Posts: 257

Posted: 08/26/13 10:49 
Could you please tell me if/what wants editing on the .htaccess to enable the dedicated IP and RapidSSL to enable me to login:- I am Using the Nova skin/theme

# This is our fallback page if any friendly URL for a profile should
# fail to be redirected. Note that this is not needed unless you
# need to send failed URLs to a custom page
# Uncomment this line for Cobalt3, Sage, Flashback skins
#SetEnv JR_FRIENDLY_FAIL lists/browse_artist/search_string=
# Uncomment for Nova skin
#SetEnv JR_FRIENDLY_FAIL lists/artists/search_string=

# Uncomment if you are using the Nova or JamTube skins and settings.cfg.php uses a WWW url
#RewriteCond %{HTTP_HOST} !^www\.
#RewriteRule (.*) http://www.%{HTTP_HOST}/$1 [R=301,L]
#
# Uncomment if you are using the Nova or JamTube skins and settings.cfg.php uses a NON WWW url
#RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
#RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

# If we come in EMPTY, just load the index
RewriteRule ^$ index.php [L]

# PAGES (templates)
# Rewrite Pattern Redirect URL Options - SEFTAG required!
RewriteRule ^pages/([^/]+) index.php?t=$1 [E=SEFTAG:pages,L]
RewriteRule ^charts/([^/]+) index.php?t=$1 [E=SEFTAG:charts,L]
RewriteRule ^lists/([^/]+) index.php?t=$1 [E=SEFTAG:lists,L]
RewriteRule ^articles/([^/]+) index.php?c=$1 [E=SEFTAG:articles,L]
RewriteRule ^signup/([^/]+) signup.php [E=SEFTAG:signup,L]
RewriteRule ^content/(.+) index.php?c=$1 [E=SEFTAG:content,L]
RewriteRule ^forum(/)+(.*)$ forum.php?band_id=0 [E=SEFTAG:forum,QSA,L]
RewriteRule ^comments(/)+(.*)$ comment.php [E=SEFTAG:comments,QSA,L]
RewriteRule ^community(/)+$ index.php?t=community [E=SEFTAG:community,QSA,L]
RewriteRule ^search(/)+$ index.php?t=search [E=SEFTAG:search,QSA,L]

# SefJam support for Link Masker
RewriteRule ^chart=([^/]+)$ sefjam.php?uf_str=$1 [L]
RewriteRule ^list=([^/]+)$ sefjam.php?uf_str=$1 [L]
RewriteRule ^page=([^/]+)$ sefjam.php?uf_str=$1 [L]

# Profiles - specific pages
RewriteCond %{SCRIPT_FILENAME} !-f
RewriteCond %{ENV:REDIRECT_STATUS} ^$
RewriteCond %{SCRIPT_FILENAME} !(([^/]+)\.css)
RewriteCond %{SCRIPT_FILENAME} !(([^/]+)\.xml)
RewriteCond %{REQUEST_URI} !^(.*epk.*)$
RewriteCond %{REQUEST_URI} !^(.*song_player.*)$
RewriteRule ^members/([0-9]+)(/.*)?$ sefjam.php?band_id=$1 [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/guestbook(/)?$ guestbook.php?mode=view_guestbook&template=script_guestbook.tpl&profile=$1 [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/epk(/)?$ epk.php?profile=$1 [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/contact(/)?$ contact.php?template=script_contact.tpl&profile=$1 [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/comments(/)?$ comment.php?mode=view_comments&type=band&template=script_comment.tpl&profile=$1 [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/share(/)?$ share.php?mode=form&template=script_share.tpl&profile=$1 [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/info(/)?$ $1/info.php [QSA,L]
RewriteRule ^([A-Za-z0-9_.-]+)/forum(/.*)?$ forum.php?profile=$1 [QSA,L]

# Profiles - entry
RewriteCond %{SCRIPT_FILENAME} !-f
RewriteCond %{SCRIPT_FILENAME} !-d
RewriteRule ^([^/]+)((/.+\.php)?/?)$ sefjam.php?uf_name=$1&uf_path=$2 [QSA,L]

Back to top
Brian
Jamroom Team


Joined: 09 Jul 2003
Posts: 37583
Location: Seattle, WA

Posted: 08/26/13 16:31 
This is your .htaccess - it is not involved with SSL. You need to make sure your Jamroom URL setting in config/settings.cgf.php is correct. You also need to contact your hosting provider and ensure SSL is setup properly for your domain.

For what it's worth, I would not recommend using SSL with JR4.

- Brian


_________________
Make sure and check out:
* The Jamroom FAQ
* The Jamroom Documentation
Back to top
ukdenny



Joined: 20 May 2008
Posts: 257

Posted: 08/27/13 02:00 
My config/settings.cfg.php are:-
$config['jamroom_url'] = 'https://soundblitzrecords.com';
$config['jamroom_cgiurl'] = 'https://soundblitzrecords.com/cgi-bin';

I have asked my hosting company to look into the setup.

I have tried to access the 'settings' but can't, so I can't change the login and I'm locked out.

Back to top
Brian
Jamroom Team


Joined: 09 Jul 2003
Posts: 37583
Location: Seattle, WA

Posted: 08/27/13 18:34 
When you say "locked out" do you mean you can't login, or are you getting a white screen?

Send me your FTP login info and JR admin login and I can check it out in the AM.

Hope this helps!

- Brian


_________________
Make sure and check out:
* The Jamroom FAQ
* The Jamroom Documentation
Back to top
ukdenny



Joined: 20 May 2008
Posts: 257

Posted: 08/28/13 00:19 
Thanks Brian,
That's now fixed and I can log in. There are the following php errors:-

28-Aug-2013 02:01:31] PHP Warning: ini_restore() has been disabled for security reasons in /home/mydreams/public_html/soundblitzrecords.com/include/jamroom-misc.inc.php on line 7528
[28-Aug-2013 02:01:31] PHP Warning: ini_restore() has been disabled for security reasons in /home/mydreams/public_html/soundblitzrecords.com/include/jamroom-misc.inc.php on line 7528
[28-Aug-2013 02:01:28] PHP Warning: is_executable() [<a href='function.is-executable'>function.is-executable</a>]: open_basedir restriction in effect. File(/usr/local/bin/curl) is not within the allowed path(s): (/home/mydreams:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/mydreams/public_html/soundblitzrecords.com/include/snoopy/Snoopy.class.php on line 370
[28-Aug-2013 01:31:57] PHP Warning: is_executable() [<a href='function.is-executable'>function.is-executable</a>]: open_basedir restriction in effect. File(/usr/local/bin/curl) is not within the allowed path(s): (/home/mydreams:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/mydreams/public_html/soundblitzrecords.com/include/snoopy/Snoopy.class.php on line 370

Is this something I could fix?

regards
Denis

Back to top
Michael
Jamroom Team


Joined: 22 Apr 2008
Posts: 3423
Location: Tokyo

Posted: 08/28/13 00:35 
The two warnings you are seeing are:

* Warning: ini_restore() has been disabled for security reasons.

* Warning: is_executable() open_basedir restriction in effect. File is not within the allowed paths

Neither of which will be under your control if you are in a shared hosting environment. My guess is they have been put in place by your hosting provider.

Not sure about the effects it will have since Jamroom is not being allowed to use them.


_________________
Michael Ussher
Jamroom Network Team Member: http://www.jamroom.net
Priority Support: http://www.jamroom.net/Support_Center
Back to top
ukdenny



Joined: 20 May 2008
Posts: 257

Posted: 08/28/13 01:30 
okay, Thanks Michael, I'll see how things go.

regards
Denis

Back to top
Display posts from previous:   
User Support Forum Archive (Read Only)
Jamroom Help

 
Solutions
• Social Media Platform
• Social Networking Software
• Musician Website Manager
• Community Builder
Products
• Jamroom Core
• Jamroom Addons
• Jamroom Modules
• Jamroom Marketplace
Support
• Support Forum
• Documentation
• Support Center
• Contact Support
Community
• Community Forum
• Member Sites
• Developers
Company
• About Us
• Contact Us
• Privacy Policy
©2003 - 2010 Talldude Networks, LLC.