Jamroom Logo Jamroom 5 Core
is now Open Source!
User Support Forum Archive (Read Only)
Jamroom Help:
Admin Blog and Articles not working for Master Admin?
micaddicts



Joined: 26 Aug 2012
Posts: 10

Posted: 09/11/12 09:49 
Exclamation JR 4.3
Exclamation ALL Skins

Editor is not showing up for my Master Admin account on all skins.
I created an Artist account and the editor was working.
I'm still a newb at this so it may be something easy.
How do I edit quota for myself? Is that the "-1" member?

Question
Thanks.

Back to top
SteveX
Ultrabubble


Joined: 30 Aug 2005
Posts: 8792
Location: Ultrabubble

Posted: 09/11/12 10:38 
Welcome to the forum!

Admin isn't in a quota, its a single, unique account. The editor for admin is turned on here:
admin options > system config > account settings, scroll down to Admin Account Settings, set Admin Editor to "yes"

The -1 quota (and all other minus quotas) are member quotas as opposed to artist quotas, the documentation explains more on these pages:
http://www.jamroom.net/Jamroom4_Account_Types
http://www.jamroom.net/Jamroom4_Quota_System


_________________
Kulshi Mezian!

"Stranger from another planet, welcome to our hole. Just strap on your guitar and we'll play some rock and roll"

Ultrabubble create things.
Back to top
micaddicts



Joined: 26 Aug 2012
Posts: 10

Posted: 09/11/12 10:41 
Admin Editor is set to "Yes".
I tried to fix this issue for over 2 hours with no luck, scrolling through threads.
I finally had to ask in the forums here.



Back to top
SteveX
Ultrabubble


Joined: 30 Aug 2005
Posts: 8792
Location: Ultrabubble

Posted: 09/11/12 11:46 
That's a strange one, especially if the editor is loading for an artist account.

I'm not really sure what to suggest, except check for javascript errors using firebug, possibly a javascript error stopping the editor from loading, and take a look at your jamroom error log as well

Have you made any template customizations at all?


_________________
Kulshi Mezian!

"Stranger from another planet, welcome to our hole. Just strap on your guitar and we'll play some rock and roll"

Ultrabubble create things.
Back to top
micaddicts



Joined: 26 Aug 2012
Posts: 10

Posted: 09/11/12 12:04 
I have made template customizations but I replaced them all with fresh again and the same thing happens. Its for all skins.

Back to top
micaddicts



Joined: 26 Aug 2012
Posts: 10

Posted: 09/11/12 12:12 
Could it be because of either of these?







Back to top
SteveX
Ultrabubble


Joined: 30 Aug 2005
Posts: 8792
Location: Ultrabubble

Posted: 09/11/12 12:24 
Unlikely to be either of those.

Whats strange is that the editor loads for an artist but not for admin (if I have that right). Do you have firebug installed in Firefox? My guess is that there is a javascript error preventing the editor from loading for admin.

Did it work for admin before and then stop working? Does it still work for your artist account?


_________________
Kulshi Mezian!

"Stranger from another planet, welcome to our hole. Just strap on your guitar and we'll play some rock and roll"

Ultrabubble create things.
Back to top
micaddicts



Joined: 26 Aug 2012
Posts: 10

Posted: 09/11/12 12:28 
Yes it still works for my Artist account.
It never worked, I went to edit the default message and found the bug.

Back to top
SteveX
Ultrabubble


Joined: 30 Aug 2005
Posts: 8792
Location: Ultrabubble

Posted: 09/11/12 12:49 
I don't think it's a Jamroom bug because the editor loads fine for me on 4.3.0 (and for everyone else too, otherwise we'd have heard about it).

Try using a different browser.

Try looking for javascript errors reported using firebug:
http://sixrevisions.com/tools/firebug-guide-web-designers/
http://gemal.dk/mozilla/development.html

You could try reuploading your jamroom files, but that's an unlikely solution since it works for your artist. (if you are using the same computer and browser for both artist and admin).


_________________
Kulshi Mezian!

"Stranger from another planet, welcome to our hole. Just strap on your guitar and we'll play some rock and roll"

Ultrabubble create things.
Back to top
Michael
Jamroom Team


Joined: 22 Apr 2008
Posts: 3423
Location: Tokyo

Posted: 09/12/12 20:30 
That "Admin Editor" setting on this page:
YOUR-SITE.com/jrconfig.php?mode=detailed_settings&section=artist&s=1

Would be the only normal thing preventing it from showing.

There is a way to force it not to show via a .cfg file or hard-code it to show/not-show via the code but neither of these should be set in a default setup.

Could you check that "Admin Editor" setting one more time please.


_________________
Michael Ussher
Jamroom Network Team Member: http://www.jamroom.net
Priority Support: http://www.jamroom.net/Support_Center
Back to top
Display posts from previous:   
User Support Forum Archive (Read Only)
Jamroom Help

 
Solutions
• Social Media Platform
• Social Networking Software
• Musician Website Manager
• Community Builder
Products
• Jamroom Core
• Jamroom Addons
• Jamroom Modules
• Jamroom Marketplace
Support
• Support Forum
• Documentation
• Support Center
• Contact Support
Community
• Community Forum
• Member Sites
• Developers
Company
• About Us
• Contact Us
• Privacy Policy
©2003 - 2010 Talldude Networks, LLC.