Jamroom Logo Jamroom 5 Core
is now Open Source!
User Support Forum Archive (Read Only)
N8Flex:
FX link to copy url on share feature?
ifeelmusic



Joined: 24 Sep 2008
Posts: 99

Posted: 08/22/11 03:36 
I don't think that it means my setup is out of date. It is 4.2.3. I think I just have the video templates set up strange on my part. If I use the popup, it works. If I use any other player besides the full, the links do not work. Again, something on my end, I'm sure.

But saying the demo works fine and there are no issues is not quite true. I have used several of your players over the past. They work beautifully for people that want to use JUST your stuff for video and songs. In the past on one project, I could not understand it at all why your players took over the whole system. Now, I do.

The problem with 'scrapping' the changes is that if someone comes along, like myself and wants to use your video player, but a different audio player, there is conflict. Your player takes over completely. The only reason my custom audio player works correctly now is because the templates for it are custom playlists. Yours are not and takes over completely as the default.

Scenario:

Jamroom implements a new change with a new version of the includes.xpsf.tpl and php. Those changes will not work for anyone who updates if they use your players because they are not seen by jamroom. They are loaded first, then yours are loaded, taking over.

As for documentation, I think Jamroom is documented pretty well if people actually take the time to study it a bit. I've read the PDF twice now and still learn new things all the time. There is a lot to it. I'm sure it could be better documented, but then again, so could lots of things.

Thanks for taking the time to look into it. I'll find the solution I am after.

Back to top
Natedogg265
N8Flash Designs


Joined: 28 Jan 2007
Posts: 5866
Location: St. Louis, Missouri

Posted: 08/22/11 03:48 
My templates are modified xspf templates. They should support any audio or video player jamroom uses. I have simply added addition fields.

But that's not the issue we have before us now. Have to tested the demo site? The player works just as it should there.


_________________
Modules, Skins, Flash Players and more.
Exclusively for Jamroom


Back to top
ifeelmusic



Joined: 24 Sep 2008
Posts: 99

Posted: 08/22/11 04:22 
I did look at the demo. it works great. I already said the issue of the player is on me, but...


Quote:

My templates are modified xspf templates. They should support any audio or video player jamroom uses. I have simply added


They didn't work for mine. But here is why. The designer did the same thing as you. Edited the same templates, etc but in the includes/jrPlaylist. He was done and all was well. Then I installed your player, never once touching the files he did. But after the install, his player was being called first, then yours because it is a module. Then... broken custom player. Once he corrected the issue by making a custom playlist. It was fine.

Not saying this is a big deal. It is rare probably that someone would have to deal with this. Just saying that in a perfect world, both would use their own custom playlists, which would never interfere with the core.

I'll be fine because I know about this issue. Just wanted to pass along the info. No sense beating a dead horse.


On a side note: you mentioned documentation. Do you have some on the module for other preferences... Is there away to turn off the email feature if I'd like?

Back to top
Natedogg265
N8Flash Designs


Joined: 28 Jan 2007
Posts: 5866
Location: St. Louis, Missouri

Posted: 08/22/11 04:40 
No the players are pretty straight forward. The more options I add the more confusion I cause.

When I mentioned documentation, I was speaking on modules an xspf playlists. I've only obtained bits and pieces of the info I need. In 3 years of selling players, no one has ever needed more than one playlist. I'll dig into that more as I get more info.

I would copy the player code from clean downloaded Nova templates and insert them into your templates.


_________________
Modules, Skins, Flash Players and more.
Exclusively for Jamroom


Back to top
ifeelmusic



Joined: 24 Sep 2008
Posts: 99

Posted: 08/22/11 04:42 
Yep. I'm looking through it now and going through it. I'll sort it out. If I come across anything else, I'll let ya know. Thanks!

Back to top
ifeelmusic



Joined: 24 Sep 2008
Posts: 99

Posted: 08/22/11 08:20 
Ok. Got it.

Can't believe all I went through for this to be the issue, but that's how it goes.

If you use the fxvp player, it works.

If you switch to fxsp player, it does not.

I tried this in 2 templates to make sure it wasn't the header include and stuff for video_player_full and then i tried it for video_player. They both did the same thing.

Too bad. I like the fxsp one better for the spot I am trying to put it.

Facebook mode must be off to see the extra trailing slash in the profile video/url.

This may be a glitch on my system, but I don't really see how at this point.

But maybe...



Another side note, Facebook mode... what is it? I know it changes the url, but why and does it do anything else?

Back to top
Display posts from previous:   
User Support Forum Archive (Read Only)
N8Flex

< Previous12
 
Solutions
• Social Media Platform
• Social Networking Software
• Musician Website Manager
• Community Builder
Products
• Jamroom Core
• Jamroom Addons
• Jamroom Modules
• Jamroom Marketplace
Support
• Support Forum
• Documentation
• Support Center
• Contact Support
Community
• Community Forum
• Member Sites
• Developers
Company
• About Us
• Contact Us
• Privacy Policy
©2003 - 2010 Talldude Networks, LLC.